Tag Archives: issue

Verizon CyanogenMod 10.1 Call/Text Issues & Solution

So, finally i upgraded my Verizon Samsung Galaxy S3 (or i535 or d2vzw) from CM 10 to CM 10.1.

From my experience with Custom ROMs – they never work the way they should in the first try.

Initially, i upgraded from within my ROM through CM Updater. It upgraded fine but not even a minute after upgrade, services stopped. The first one to go was the Clock. Then went the com.android.phone. I forgot to flash Gapps 4.2 which took me a while to figure out why Google apps won’t work!

After reading a few blogs and comments in forums, i gave it another chance. This time i flashed the CM 10.1 rom via ClockworkMod Recovery. And, i flashed the Gapps 4.2.

Like other times, i wasn’t expecting this installation to work correctly the first time. The phone rebooted and i waited.. completed a couple steps..and waited.. while it tried it best to activate. Waited for 10 minutes patiently. Gave up and powered it down.

Again, i went to the forums to see what was wrong this time. I found out a lot of people had issues with CM 10.1 nightlies. I finally found a solution to the network problems.

Here’s what i did to fix it:

1. Started up the phone.

2. It tried to activate the phone again. After sometime, it gave me an error that the network couldn’t be activated and if i would like to use the WiFi instead.

3. Connected to a Wifi.

4. The phone started just fine. Everything worked except Calls/Text.

5. As mentioned on some of the forums, i took the Sim Card out while the phone was still on. Let it sit for 2 minutes.

6. Inserted the Sim back in.

7. Went to Settings > More > Mobile Networks.

8. Clicked on “CDMA Subscription”.

9. Selected “RUIM/SIM” as option.

10. Went back and it started working. I could not make Calls and send/receive texts.

I restarted the phone just to make sure i don’t lose it again. But, it still worked after restart.

Let me know if it worked for you guys.

Advertisements
Tagged , , , , , , , , , , , , , , , ,